Linux运维之路


华为HCNP_06.IP地址分类_静态路由配置

admin 2019-05-03 438浏览 0条评论
首页/正文
分享到: / / / /

静态路由

ENSP模拟器使用路由器 最好用 Router 初学不要用AR系列

拖拽一台Router路由器 右键启动它

停止设备

基础拓扑:

ESNP模式讲解

< user-viewer> : 用户视图模式: 权限低 执行调试,查看类指令

[ system-viewer ] : 系统试图模式: 配置修改

sysname : 重命名

undo 退回某一个操作[如 通过sysname R1 可以通过 undo sysname 来退回修改]

模式进入与退出

< user-viewer> 进入 [ system-viewer ] 输入命令: system-view

[ system-viewer ] 退回 < user-viewer> 输入命令: quit

sysname R1: 将路由器名字改为 R1

优化日志消息:

每次修改配置都会弹出消息,如果不需要可以关闭消息

[R1] undo info-center enable — 关闭消息通知 Info: Information center is disabled.

消息通知示例:

May 2 2019 07:36:26-08:00 R1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25. 191.3.1 configurations have been changed. The current change number is 1, the ch ange loop count is 0, and the maximum number of records is 4095.

优化日志显示:

language-mode Chinese

language-mode Chinese Change language mode, confirm? [Y/N] y —默认提示语言改为中文

提示:改变语言模式成功。

命令帮助:

ensp 可以使用 ? 获取命令帮助

例如忘记了 特权模式怎么进去 只知道是 s 开头 可以使用 s? 来获取帮助

<R1>s?      <---命令帮助示例
  save                                    schedule
  screen-length                           screen-width
  send                                    set
  sslvpn                                  start-script
  startup                                 super
  system-view                             

ensp 还可以可以使用tab键补全命令

如:

sslvpn super system-view schedule save startup 这些命令都是 我只按了一个s 然后按tab键出来的提示命令

快捷键

​ 可以通过 ctrl +z 退回用户模式

配置查看:

dis current-configuration <—查看当前系统所有接口正在使用的配置 可以简写为: dis cu

save 保存配置

dis ip int brief 《---显示接口配置信息

dis ip routing-table 查看路由表

直连路由配置:

路由器属于三层设备,接口必须配置ip地址才可以生效,如果不配置,该借口无法传输数据

交换机属于二层设备,该设备不需要配置ip就可以转发数据包。

华为路由器接口:

华为查看接口速率,e开头的是100mbps G开头的是1000mbps

公司常见网络配置:

R1配置:

<R1>system-view 
[R1] int e0/0/0
[R1-Ethernet0/0/0]ip add 192.168.1.1 24
[R1-Ethernet0/0/0]int g0/0/0
[R1-GigabitEthernet0/0/0]ip add 12.1.1.1 24

配置R1到R3默认路由
ip route-static 192.168.2.0 24 12.1.1.2

R2配置:

undo info-center enable
interface Ethernet0/0/0
 ip address 12.1.1.2 255.255.255.0
 
interface Ethernet0/0/1
 ip address 23.1.1.1 255.255.255.0
 
 静态路由配置:
 [Huawei]ip route-static 192.168.2.0 24 23.1.1.2
 [Huawei]ip route-static 192.168.1.0 24 12.1.1.1

R3配置:

interface Ethernet0/0/1
 ip address 192.168.2.1 255.255.255.0
interface Ethernet0/0/0
 ip address 23.1.1.2 255.255.255.0
 
 配置R3到R1默认路由
ip route-static 192.168.1.0 24 23.1.1.1

静态路由配置:

查看当前已有路由配置 dis ip routing-table

以上配置注意: 中间的 R2 需要有两端无法到达的路由网段路由

所以需要手动配置路由到达各个地址

R3关键配置:

[Huawei]ip route-static 192.168.2.0 24 23.1.1.2 [Huawei]ip route-static 192.168.1.0 24 12.1.1.1

还有两端路由器的路由:

R1添加: ip route-static 23.1.1.0 24 12.1.1.2

R3添加: ip route-static 12.1.1.0 24 23.1.1.1

配置完毕后 R1和ping R3 PC1可以pingPC2,反之也可以

在路由器上ping另一台主机,源地址为路由器出口地址

最后修改:2019-05-03 20:29:48 © 著作权归作者所有
如果觉得我的文章对你有用,请随意赞赏
扫一扫支付

上一篇

发表评论

评论列表

还没有人评论哦~赶快抢占沙发吧~