Linux运维之路


华为HCNP_10.动态路由_rip协议_路由汇总_静默接口

admin 2019-05-22 592浏览 0条评论
首页/正文
分享到: / / / /

rip路由汇总

实验拓扑:

通过配置让各个网段互通,并且使得路由表精简

配置:

R1:

interface Ethernet0/0/0
 ip address 12.1.1.1 255.255.255.0
#
interface Ethernet0/0/1
 ip address 23.1.1.1 255.255.255.0
#
interface LoopBack1
 ip address 192.168.10.1 255.255.255.0
#

##路由表:
[Huawei]dis ip routing-table 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 9        Routes : 9        

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       12.1.1.0/24  Direct  0    0           D   12.1.1.1        Ethernet0/0/0
       12.1.1.1/32  Direct  0    0           D   127.0.0.1       Ethernet0/0/0
       13.1.1.0/24  RIP     100  1           D   12.1.1.2        Ethernet0/0/0
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
     172.16.1.0/24  RIP     100  2           D   12.1.1.2        Ethernet0/0/0
    192.168.1.0/24  RIP     100  1           D   12.1.1.2        Ethernet0/0/0
   192.168.10.0/24  Direct  0    0           D   192.168.10.1    LoopBack1
   192.168.10.1/32  Direct  0    0           D   127.0.0.1       LoopBack1

R3: 配置loopback接口:

interface LoopBack0
 ip address 3.3.3.3 255.255.255.0
#
interface LoopBack1
 ip address 3.3.2.3 255.255.255.0
#
interface LoopBack2
 ip address 3.3.1.3 255.255.255.0
#
interface Ethernet0/0/0
 ip address 23.1.1.2 255.255.255.0
#
interface Ethernet0/0/1
 ip address 172.16.1.1 255.255.255.0

R3:rip配置:

rip 1
version 2
network 3.0.0.0


检查配置:
[Huawei-rip-1]dis this
#
rip 1
 version 2
 network 23.0.0.0
 network 172.16.0.0
 network 13.0.0.0
 network 3.0.0.0
#
return

R3: 开启路由汇总

[Huawei-GigabitEthernet0/0/0]rip summary-address 3.3.0.0 255.255.255.0
[Huawei-GigabitEthernet0/0/0]dis this
#
interface GigabitEthernet0/0/0
 ip address 13.1.1.2 255.255.255.0
 rip summary-address 3.3.0.0 255.255.0.0   
#
return

通过以上配置会将把多条路由缩减为几条路由甚至一条路由,用于减少路由表,因为路由表越大,处理速度越慢

静默接口(rip优化)

作用: 减少不必要的rip更新报文发向用户,减少链路贷款占用

rip协议每隔30秒宣告自身路由,如果出现大量宣告出现,会导致网络阻塞,因为交换机可能会群发

静默接口配置:

rip 1
version 2
silent-interface e0/0/0  ##[静默接口后,路由器将不在从该接口向外发送任何rip更新,但不影响rip共享,不影响网络]
最后修改:2019-05-22 05:07:00 © 著作权归作者所有
如果觉得我的文章对你有用,请随意赞赏
扫一扫支付

上一篇

发表评论

评论列表

还没有人评论哦~赶快抢占沙发吧~