Linux运维之路


华为HCNP_11.动态路由_OSPF协议_配置与原理简介(基础篇)

admin 2019-05-28 387浏览 0条评论
首页/正文
分享到: / / / /

ospf [ospf hcna篇]

OSPF简介

OSPF: 开放式最短路径优先(Open Shorttest Path First)协议

它是IETF定义的一种基于链路状态的内部网关路由协议

rip: rip是一种基于 距离矢量算法的路由协议,存在着收敛慢,容易产生环路,可扩展性差等问题

目前该协议已经逐渐被OSPF取代,作为网络管理员 rip ospf都应该理解

OSPF基本配置

拓扑图:

R2基础配置:

<Huawei>sys
[Huawei]un en inf

[Huawei]interface Ethernet0/0/0
[Huawei-Ethernet0/0/0]ip address 12.1.1.1 255.255.255.0

[Huawei]interface Ethernet0/0/1
[Huawei-Ethernet0/0/1]ip address 23.1.1.1 255.255.255.0

[Huawei] interface LoopBack0
[Huawei-LoopBack0] ip address 192.168.10.1 255.255.255.0

R1基础配置:

<Huawei>sys
[Huawei]un in en

[Huawei] interface Ethernet0/0/0
[Huawei-Ethernet0/0/0] ip address 12.1.1.2 255.255.255.0

[Huawei-Ethernet0/0/0]int e0/0/1
[Huawei-Ethernet0/0/1] ip address 192.168.1.1 255.255.255.0

R3基础配置:

<Huawei>sys
[Huawei]un in en

[Huawei]int e0/0/0
[Huawei-Ethernet0/0/0]ip add 23.1.1.2 24
[Huawei]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip add 34.1.1.1 24
[Huawei]int e0/0/1
[Huawei-Ethernet0/0/1]ip add 192.168.5.1 24

R4基础配置:

[Huawei]interface LoopBack0
[Huawei-LoopBack0] ip address 4.4.4.4 255.255.255.0
[Huawei] interface Ethernet0/0/0
[Huawei-Ethernet0/0/0]ip address 34.1.1.2 255.255.255.0

OSPF关键配置:

R1:

[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 12.1.1.0 0.0.0.255

[Huawei-ospf-1]dis this
#
ospf 1
 area 0.0.0.0
  network 192.168.1.0 0.0.0.255
  network 12.1.1.0 0.0.0.255
#
return

R2:

[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 12.1.1.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255

[Huawei-ospf-1-area-0.0.0.0]dis this    ## 查看配置
#
 area 0.0.0.0
  network 12.1.1.0 0.0.0.255
  network 23.1.1.0 0.0.0.255
  network 192.168.10.0 0.0.0.255
#
return

R3:

[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 34.1.1.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255

[Huawei-ospf-1-area-0.0.0.0]dis this
#
 area 0.0.0.0
  network 23.1.1.0 0.0.0.255
  network 34.1.1.0 0.0.0.255
  network 192.168.5.0 0.0.0.255
#
return

R4:

[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 34.1.1.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 4.4.4.0 0.0.0.255

[Huawei-ospf-1-area-0.0.0.0]dis this
#
 area 0.0.0.0
  network 34.1.1.0 0.0.0.255
  network 4.4.4.0 0.0.0.255
#
return

PC配置:

R1:

PC2:

测试ping:

PC1 ping PC2:

PC2pingPC1:

PC1ping 青岛分局 4.4.4.4

至此,整个网络已经通过ospf协议完成了全往互通

OSPF原理分析

抓包分析:看到上图 我们可以从 R1 --- R2之间 抓包查看数据报文

通过报文可以看到 每隔 10 秒 ospf报文会发送一次hello包(rip30秒发送一次),这个hello包不是传递路由 而是建立连接,检查是否存活

OSPF 5种报文:

  1. hello包 [检测邻接关系是否建立存在]

  2. DBD数据库描述报文

  3. LSR链路状态请求报文

  4. LSU链路状态回应报文

  5. LSack链路状态确认报文

    • 注意: ospf 在邻居刚建立的时候会发送路由信息(路由信息使用DBD,LSR,LSU,LSack 四种报文来发送)

    • 路由同步后,后面仅靠hello包来维持邻居关系

开启抓包,然后通过重置ospf进程来查看相关报文的传输:

reset ospf process #用于重置ospf进程。

重置后,查看抓包

这里可以查看到ospf建立过程和5种报文的发送情况

  • 附件

ospf协议配置.zip

最后修改:2019-05-28 12:29:59 © 著作权归作者所有
如果觉得我的文章对你有用,请随意赞赏
扫一扫支付

上一篇

发表评论

评论列表

还没有人评论哦~赶快抢占沙发吧~